#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " (?=(?:(?:\\.|"(?:\\.|[^"\\])*"|[^\\'"])*'(?:\\.|"(?:\\.|[^"'\\])*"|[^\\'])*')*(?:\\.|"(?:\\.|[^"\\])*"|[^\\'])*$)(?=(?:(?:\\.|'(?:\\.|[^'\\])*'|[^\\'"])*"(?:\\.|'(?:\\.|[^'"\\])*'|[^\\"])*")*(?:\\.|'(?:\\.|[^'\\])*'|[^\\"])*$)"
Local $sString = ""Hello", he said. "What's up, \"doc\"?", she replied. " & @CRLF & _
"'I need a 12" crash cymbal', he reminded her. " & @CRLF & _
""2\" by 4 inches", 'Back\"\'slashes \\ are OK!'" & @CRLF & _
"" & @CRLF & _
"key : string" & @CRLF & _
"dragon : "Felix's pet"" & @CRLF & _
""Hello World" something here "Another String""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)