const regex = / (?=(?:(?:\\.|"(?:\\.|[^"\\])*"|[^\\'"])*'(?:\\.|"(?:\\.|[^"'\\])*"|[^\\'])*')*(?:\\.|"(?:\\.|[^"\\])*"|[^\\'])*$)(?=(?:(?:\\.|'(?:\\.|[^'\\])*'|[^\\'"])*"(?:\\.|'(?:\\.|[^'"\\])*'|[^\\"])*")*(?:\\.|'(?:\\.|[^'\\])*'|[^\\"])*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?=(?:(?:\\\\.|"(?:\\\\.|[^"\\\\])*"|[^\\\\\'"])*\'(?:\\\\.|"(?:\\\\.|[^"\'\\\\])*"|[^\\\\\'])*\')*(?:\\\\.|"(?:\\\\.|[^"\\\\])*"|[^\\\\\'])*$)(?=(?:(?:\\\\.|\'(?:\\\\.|[^\'\\\\])*\'|[^\\\\\'"])*"(?:\\\\.|\'(?:\\\\.|[^\'"\\\\])*\'|[^\\\\"])*")*(?:\\\\.|\'(?:\\\\.|[^\'\\\\])*\'|[^\\\\"])*$)', 'g')
const str = `"Hello", he said. "What's up, \\"doc\\"?", she replied.
'I need a 12" crash cymbal', he reminded her.
"2\\" by 4 inches", 'Back\\"\\'slashes \\\\ are OK!'
key : string
dragon : "Felix's pet"
"Hello World" something here "Another String"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);