re = / (?=(?:(?:\\.|"(?:\\.|[^"\\])*"|[^\\'"])*'(?:\\.|"(?:\\.|[^"'\\])*"|[^\\'])*')*(?:\\.|"(?:\\.|[^"\\])*"|[^\\'])*$)(?=(?:(?:\\.|'(?:\\.|[^'\\])*'|[^\\'"])*"(?:\\.|'(?:\\.|[^'"\\])*'|[^\\"])*")*(?:\\.|'(?:\\.|[^'\\])*'|[^\\"])*$)/
str = '"Hello", he said. "What\'s up, \\"doc\\"?", she replied.
\'I need a 12" crash cymbal\', he reminded her.
"2\\" by 4 inches", \'Back\\"\\\'slashes \\\\ are OK!\'
key : string
dragon : "Felix\'s pet"
"Hello World" something here "Another String"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result