$re = '/ (?=(?:(?:\\\\.|"(?:\\\\.|[^"\\\\])*"|[^\\\\\'"])*\'(?:\\\\.|"(?:\\\\.|[^"\'\\\\])*"|[^\\\\\'])*\')*(?:\\\\.|"(?:\\\\.|[^"\\\\])*"|[^\\\\\'])*$)(?=(?:(?:\\\\.|\'(?:\\\\.|[^\'\\\\])*\'|[^\\\\\'"])*"(?:\\\\.|\'(?:\\\\.|[^\'"\\\\])*\'|[^\\\\"])*")*(?:\\\\.|\'(?:\\\\.|[^\'\\\\])*\'|[^\\\\"])*$)/';
$str = '"Hello", he said. "What\'s up, \\"doc\\"?", she replied.
\'I need a 12" crash cymbal\', he reminded her.
"2\\" by 4 inches", \'Back\\"\\\'slashes \\\\ are OK!\'
key : string
dragon : "Felix\'s pet"
"Hello World" something here "Another String"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;