import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?=(?:(?:\\\\.|\"(?:\\\\.|[^\"\\\\])*\"|[^\\\\'\"])*'(?:\\\\.|\"(?:\\\\.|[^\"'\\\\])*\"|[^\\\\'])*')*(?:\\\\.|\"(?:\\\\.|[^\"\\\\])*\"|[^\\\\'])*$)(?=(?:(?:\\\\.|'(?:\\\\.|[^'\\\\])*'|[^\\\\'\"])*\"(?:\\\\.|'(?:\\\\.|[^'\"\\\\])*'|[^\\\\\"])*\")*(?:\\\\.|'(?:\\\\.|[^'\\\\])*'|[^\\\\\"])*$)";
final String string = "\"Hello\", he said. \"What's up, \\\"doc\\\"?\", she replied. \n"
+ "'I need a 12\" crash cymbal', he reminded her. \n"
+ "\"2\\\" by 4 inches\", 'Back\\\"\\'slashes \\\\ are OK!'\n\n"
+ "key : string\n"
+ "dragon : \"Felix's pet\"\n"
+ "\"Hello World\" something here \"Another String\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}