use strict;
my $str = '"Hello", he said. "What\'s up, \\"doc\\"?", she replied.
\'I need a 12" crash cymbal\', he reminded her.
"2\\" by 4 inches", \'Back\\"\\\'slashes \\\\ are OK!\'
key : string
dragon : "Felix\'s pet"
"Hello World" something here "Another String"';
my $regex = qr/ (?=(?:(?:\\.|"(?:\\.|[^"\\])*"|[^\\'"])*'(?:\\.|"(?:\\.|[^"'\\])*"|[^\\'])*')*(?:\\.|"(?:\\.|[^"\\])*"|[^\\'])*$)(?=(?:(?:\\.|'(?:\\.|[^'\\])*'|[^\\'"])*"(?:\\.|'(?:\\.|[^'"\\])*'|[^\\"])*")*(?:\\.|'(?:\\.|[^'\\])*'|[^\\"])*$)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";