import re
regex = re.compile(r" (?=(?:(?:\\.|\"(?:\\.|[^\"\\])*\"|[^\\'\"])*'(?:\\.|\"(?:\\.|[^\"'\\])*\"|[^\\'])*')*(?:\\.|\"(?:\\.|[^\"\\])*\"|[^\\'])*$)(?=(?:(?:\\.|'(?:\\.|[^'\\])*'|[^\\'\"])*\"(?:\\.|'(?:\\.|[^'\"\\])*'|[^\\\"])*\")*(?:\\.|'(?:\\.|[^'\\])*'|[^\\\"])*$)")
test_str = ("\"Hello\", he said. \"What's up, \\\"doc\\\"?\", she replied. \n"
"'I need a 12\" crash cymbal', he reminded her. \n"
"\"2\\\" by 4 inches\", 'Back\\\"\\'slashes \\\\ are OK!'\n\n"
"key : string\n"
"dragon : \"Felix's pet\"\n"
"\"Hello World\" something here \"Another String\"")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)