using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?=(?:(?:\\.|""(?:\\.|[^""\\])*""|[^\\'""])*'(?:\\.|""(?:\\.|[^""'\\])*""|[^\\'])*')*(?:\\.|""(?:\\.|[^""\\])*""|[^\\'])*$)(?=(?:(?:\\.|'(?:\\.|[^'\\])*'|[^\\'""])*""(?:\\.|'(?:\\.|[^'""\\])*'|[^\\""])*"")*(?:\\.|'(?:\\.|[^'\\])*'|[^\\""])*$)";
string substitution = @"";
string input = @"""Hello"", he said. ""What's up, \""doc\""?"", she replied.
'I need a 12"" crash cymbal', he reminded her.
""2\"" by 4 inches"", 'Back\""\'slashes \\ are OK!'
key : string
dragon : ""Felix's pet""
""Hello World"" something here ""Another String""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}