#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)__tests__\/.*(\.silent)\.(jsx?|tsx?)$"
Local $sString = "/__tests__/file0.silent.js" & @CRLF & _
"/__tests__/file1.silent.ts" & @CRLF & _
"/__tests__/file2.silent.jsx" & @CRLF & _
"/__tests__/file3.silent.tsx" & @CRLF & _
"" & @CRLF & _
"/__tests__/file4.js" & @CRLF & _
"/__tests__/file5.ts" & @CRLF & _
"/__tests__/file6.jsx" & @CRLF & _
"/__tests__/file7.tsx" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"__tests__\/(?!.*silent).*(jsx?|tsx?)$" & @CRLF & _
"__tests__\/.*(\.silent)\.(jsx?|tsx?)$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")