using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__tests__\/.*(\.silent)\.(jsx?|tsx?)$";
string input = @"/__tests__/file0.silent.js
/__tests__/file1.silent.ts
/__tests__/file2.silent.jsx
/__tests__/file3.silent.tsx
/__tests__/file4.js
/__tests__/file5.ts
/__tests__/file6.jsx
/__tests__/file7.tsx
__tests__\/(?!.*silent).*(jsx?|tsx?)$
__tests__\/.*(\.silent)\.(jsx?|tsx?)$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}