package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)__tests__\/.*(\.silent)\.(jsx?|tsx?)$`)
var str = `/__tests__/file0.silent.js
/__tests__/file1.silent.ts
/__tests__/file2.silent.jsx
/__tests__/file3.silent.tsx
/__tests__/file4.js
/__tests__/file5.ts
/__tests__/file6.jsx
/__tests__/file7.tsx
__tests__\/(?!.*silent).*(jsx?|tsx?)$
__tests__\/.*(\.silent)\.(jsx?|tsx?)$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}