# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"__tests__\/.*(\.silent)\.(jsx?|tsx?)$"
test_str = ("/__tests__/file0.silent.js\n"
"/__tests__/file1.silent.ts\n"
"/__tests__/file2.silent.jsx\n"
"/__tests__/file3.silent.tsx\n\n"
"/__tests__/file4.js\n"
"/__tests__/file5.ts\n"
"/__tests__/file6.jsx\n"
"/__tests__/file7.tsx\n\n\n"
"__tests__\\/(?!.*silent).*(jsx?|tsx?)$\n"
"__tests__\\/.*(\\.silent)\\.(jsx?|tsx?)$")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.