const regex = /__tests__\/.*(\.silent)\.(jsx?|tsx?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__tests__\\\/.*(\\.silent)\\.(jsx?|tsx?)$', 'gm')
const str = `/__tests__/file0.silent.js
/__tests__/file1.silent.ts
/__tests__/file2.silent.jsx
/__tests__/file3.silent.tsx
/__tests__/file4.js
/__tests__/file5.ts
/__tests__/file6.jsx
/__tests__/file7.tsx
__tests__\\/(?!.*silent).*(jsx?|tsx?)\$
__tests__\\/.*(\\.silent)\\.(jsx?|tsx?)\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}