$re = '/__tests__\/.*(\.silent)\.(jsx?|tsx?)$/m';
$str = '/__tests__/file0.silent.js
/__tests__/file1.silent.ts
/__tests__/file2.silent.jsx
/__tests__/file3.silent.tsx
/__tests__/file4.js
/__tests__/file5.ts
/__tests__/file6.jsx
/__tests__/file7.tsx
__tests__\\/(?!.*silent).*(jsx?|tsx?)$
__tests__\\/.*(\\.silent)\\.(jsx?|tsx?)$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);