import Foundation
let pattern = #"__tests__\/.*(\.silent)\.(jsx?|tsx?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/__tests__/file0.silent.js
/__tests__/file1.silent.ts
/__tests__/file2.silent.jsx
/__tests__/file3.silent.tsx
/__tests__/file4.js
/__tests__/file5.ts
/__tests__/file6.jsx
/__tests__/file7.tsx
__tests__\/(?!.*silent).*(jsx?|tsx?)$
__tests__\/.*(\.silent)\.(jsx?|tsx?)$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)