use strict;
my $str = '/__tests__/file0.silent.js
/__tests__/file1.silent.ts
/__tests__/file2.silent.jsx
/__tests__/file3.silent.tsx
/__tests__/file4.js
/__tests__/file5.ts
/__tests__/file6.jsx
/__tests__/file7.tsx
__tests__\\/(?!.*silent).*(jsx?|tsx?)$
__tests__\\/.*(\\.silent)\\.(jsx?|tsx?)$';
my $regex = qr/__tests__\/.*(\.silent)\.(jsx?|tsx?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}