#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint"
Local $sString = "good examples:" & @CRLF & _
"http://test.discuss.io/recruit?d=532719&s=cint" & @CRLF & _
"" & @CRLF & _
"bad examples: #should not match" & @CRLF & _
"/top2120/welcome/" & @CRLF & _
"/t/2121.html" & @CRLF & _
"/t/2124/bla.html" & @CRLF & _
"/blabla21051.html" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")