import Foundation
let pattern = #"http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
good examples:
http://test.discuss.io/recruit?d=532719&s=cint
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)