package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint`)
var str = `good examples:
http://test.discuss.io/recruit?d=532719&s=cint
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}