const regex = /http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/test\\.discuss\\.io\\\/recruit\\?d=(\\d+)\\&s=cint', 'gim')
const str = `good examples:
http://test.discuss.io/recruit?d=532719&s=cint
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}