# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint"
test_str = ("good examples:\n"
"http://test.discuss.io/recruit?d=532719&s=cint\n\n"
"bad examples: #should not match\n"
"/top2120/welcome/\n"
"/t/2121.html\n"
"/t/2124/bla.html\n"
"/blabla21051.html\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.