re = /http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint/im
str = 'good examples:
http://test.discuss.io/recruit?d=532719&s=cint
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end