using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint";
string input = @"good examples:
http://test.discuss.io/recruit?d=532719&s=cint
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}