// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)http:\/\/test\.discuss\.io\/recruit\?d=(\d+)\&s=cint").unwrap();
let string = "good examples:
http://test.discuss.io/recruit?d=532719&s=cint
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}