# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])/\n/g;t' <<< "(13-1)*(12-10)/(21+10)*(14-10)"