use strict;
my $str = '(13-1)*(12-10)/(21+10)*(14-10)';
my $regex = qr/\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";