const regex = /\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b|(?<=[()])(?=[^\\d()])|(?<=[^\\d()])(?=[()])', 'g')
const str = `(13-1)*(12-10)/(21+10)*(14-10)`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);