re = /\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])/
str = '(13-1)*(12-10)/(21+10)*(14-10)'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result