import Foundation
let pattern = #"\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"(13-1)*(12-10)/(21+10)*(14-10)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)