# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/create\sor\sreplace\spackage\sbody\ssomething\.(\S*).*/$1/gm;t' <<< "create or replace package body something.pkg_test is"