re = /create\sor\sreplace\spackage\sbody\ssomething\.(\S*).*/m
str = 'create or replace package body something.pkg_test is'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result