$re = '/create\sor\sreplace\spackage\sbody\ssomething\.(\S*).*/m';
$str = 'create or replace package body something.pkg_test is';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;