// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)create\sor\sreplace\spackage\sbody\ssomething\.(\S*).*").unwrap();
let string = "create or replace package body something.pkg_test is";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}