using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"create\sor\sreplace\spackage\sbody\ssomething\.(\S*).*";
string substitution = @"$1";
string input = @"create or replace package body something.pkg_test is";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}