import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{0,13}\\w\\b\\K.*";
final String string = "Hell, how is she today ?\n"
+ "Lorem ipsum dolor sit amet, consetetur\n"
+ "Lorem ipsum dolor sit amet\n"
+ "Lorem ipsum dolor sit\n"
+ "Lorem ipsum\n"
+ "Lorem";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}