const regex = /^.{0,13}\w\b\K.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{0,13}\\w\\b\\K.*', 'gm')
const str = `Hell, how is she today ?
Lorem ipsum dolor sit amet, consetetur
Lorem ipsum dolor sit amet
Lorem ipsum dolor sit
Lorem ipsum
Lorem`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);