# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-zA-Z ]+/ /gm;t' <<< "日本語フレーズ A Japanese phrase A Japanese phrase 日本語フレーズ"