import re
regex = re.compile(r"[a-zA-Z ]+", flags=re.MULTILINE)
test_str = "日本語フレーズ A Japanese phrase A Japanese phrase 日本語フレーズ"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)