re = /[a-zA-Z ]+/m
str = '日本語フレーズ A Japanese phrase A Japanese phrase 日本語フレーズ'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result