# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[[^\]\[]*)70/\180/gm;t' <<< "filter [70.00-140.00]"