const regex = /(\[[^\]\[]*)70/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[[^\\]\\[]*)70', 'gm')
const str = `filter [70.00-140.00]`;
const subst = `\180`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);