import re
regex = re.compile(r"(\[[^\]\[]*)70", flags=re.MULTILINE)
test_str = "filter [70.00-140.00]"
subst = "\\180"
result = regex.sub(subst, test_str)
if result:
print(result)