use strict;
my $str = 'filter [70.00-140.00]';
my $regex = qr/(\[[^\]\[]*)70/mp;
my $subst = '\\180';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";