import Foundation
let pattern = #"(\[[^\]\[]*)70"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"filter [70.00-140.00]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\180"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)