#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?|"((?:(?!",).)*)"|\h*([^,"]+))"
Local $sString = ""A", "B", "C - "G"", "D, F", 5, "A", "B", "C - "G"", "D,F,"G"F,Z,K", "A", "B", "C - "G"", "B", "C - "G"", "D,F,"G"F,Z,K", 1,"A",5, A,"D,8""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")