import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|\"((?:(?!\",).)*)\"|\\h*([^,\"]+))";
final String string = "\"A\", \"B\", \"C - \"G\"\", \"D, F\", 5, \"A\", \"B\", \"C - \"G\"\", \"D,F,\"G\"F,Z,K\", \"A\", \"B\", \"C - \"G\"\", \"B\", \"C - \"G\"\", \"D,F,\"G\"F,Z,K\", 1,\"A\",5, A,\"D,8\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}