using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|""((?:(?!"",).)*)""|\h*([^,""]+))";
string input = @"""A"", ""B"", ""C - ""G"", ""D, F"", 5, ""A"", ""B"", ""C - ""G"", ""D,F,""G""F,Z,K"", ""A"", ""B"", ""C - ""G"", ""B"", ""C - ""G"", ""D,F,""G""F,Z,K"", 1,""A"",5, A,""D,8""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}