re = /(?|"((?:(?!",).)*)"|\h*([^,"]+))/
str = '"A", "B", "C - "G"", "D, F", 5, "A", "B", "C - "G"", "D,F,"G"F,Z,K", "A", "B", "C - "G"", "B", "C - "G"", "D,F,"G"F,Z,K", 1,"A",5, A,"D,8"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end