import re
regex = re.compile(r"(?|\"((?:(?!\",).)*)\"|\h*([^,\"]+))")
test_str = "\"A\", \"B\", \"C - \"G\"\", \"D, F\", 5, \"A\", \"B\", \"C - \"G\"\", \"D,F,\"G\"F,Z,K\", \"A\", \"B\", \"C - \"G\"\", \"B\", \"C - \"G\"\", \"D,F,\"G\"F,Z,K\", 1,\"A\",5, A,\"D,8\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")