import Foundation
let pattern = #"(?|"((?:(?!",).)*)"|\h*([^,"]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""A", "B", "C - "G"", "D, F", 5, "A", "B", "C - "G"", "D,F,"G"F,Z,K", "A", "B", "C - "G"", "B", "C - "G"", "D,F,"G"F,Z,K", 1,"A",5, A,"D,8""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)